Nowsms error after sending first sms

Nowsms error after sending first sms SearchSearch

SMS & MMS Technical Forum » NowSMS Support - SMS Issues (Product Support Only) » Archive through October 19, 2005 » Nowsms error after sending first sms « Previous || Next »
Author Message
chkoh
Unregistered guest
Posted on Thursday, September 01, 2005 - 04:47 pm:   

Hi All,
I observed a problem when using nowsms v5.51 (b20040823) with T68 and DCU-11 cable, on WinXP.

I installed the T68 as COM4 on my PC. After that, I could test and add COM4 to nowSMS.

When I send a SMS from web, I can receive that SMS. However, after that, I cant send anymore, until I plugged out and insert back in the USB cable, and remove COM4 from sms connection list then add COM4 back in again to nowsms.

When I checked the log, it showed:

01:12:03:093 [2] ThreadProcessModem: Before ModemAllocate - COM4:
01:12:03:093 [2] ThreadProcessModem: After ModemAllocate - COM4: - OK
01:12:03:093 [2] ThreadProcessModem: Re-initializing modem: COM4: ...
01:12:06:000 [2] TestModemSpeed: Initialised modem at 115200 bps
01:12:07:125 [2] ThreadProcessModem: Modem initialization complete: COM4:
01:12:07:156 [2] ThreadProcessModem: Processing 430CB18B.req...
01:12:07:156 [2] ThreadProcessModem: OUT: AT+CMGS=15

01:12:07:375 [2] ThreadProcessModem: IN:
>
01:12:07:375 [2] ThreadProcessModem: OUT: 0001000A811032913126000003F8BC1E
01:14:08:125 [2] ThreadProcessModem: ERROR - Error waiting for response from modem (2)
01:14:08:125 [2] ThreadProcessModem: Error: ERROR - Error waiting for response from modem (2)

I read similar post before and the recommendation was try to add a standard modem to use that COM. But exactly same result for me even when I added a Standard 9600 modem to use this COM4, then asked nowsms to use this standard modem.

Does it look like a driver issue ? I am using the Ericsson standard DCU-11 USB-Serial driver.
Bryce Norwood - NowSMS Support
Board Administrator
Username: Bryce

Post Number: 4856
Registered: 10-2002
Posted on Thursday, September 01, 2005 - 07:01 pm:   

It does look like a driver issue ... maybe try another USB port.

Basically, we're waiting 2 minutes for a response from the modem, and it's not sending one.

I'd be curious what happens if you go into HyperTerminal (Programs/Accessories/Communications/HyperTerminal), and open a connection directly to the COM port.

Type ATZ and press Enter, the modem should respond OK.

Next type in the following sequnce (enter after each line):

AT+CSMS=0
(should respond OK)
AT+CMGF=0
(should respond OK)
AT+CMGS=15
(should respond >)

When sending the next command, use CTRL-Z at the end of the line instead of Enter:

0001000A811032913126000003F8BC1E

Does any respond come back from the modem?

If it works via HyperTerminal but not from NowSMS, then I don't know what to suggest.

My guess is that it could be a cable issue. One reason that we might not see a response come back would be if some of the bytes of data that we are sending don't make it to the modem.

Some generic cables can be of dubious quality ...

If you use the "Standard 9600 modem" driver, you could configure the Max port speed to a value lower than 115200, which might make a difference.

-bn
chkoh
Unregistered guest
Posted on Friday, September 02, 2005 - 07:23 pm:   

Hi Bryce,

Thanks for your prompt reply.
I tried your HT method, as expected, it hang after the last command, see below:

ATZ
OK
AT+CSMS=0
+CSMS: 1, 1, 1

OK
AT+CMGF=0
OK
AT+CMGS=15
> 0001000A811032913126000003F8BC1E Ctrl-Z <-- hang after here, but I did receive the SMS.

Changing to another USB port did not help as well. I also tried playing with the max port speed (when using standard 9600 modem method) to other setting eg 2400, 4800, 9600, but still the same. :-(
ashot shahbazian
New member
Username: Animatele

Post Number: 42
Registered: 06-2004
Posted on Saturday, September 10, 2005 - 12:14 am:   

Looks like a USB driver issue indeed. Try using a serial cable and connect the handset to your PC-s COM port.

I'd also suggest to remove any Ericsson software before doing it, and then to search for T68-s .INI file, right-click on it and select "Install".

Then connect the handset and install the modem manually, selecting T68 from the list of available modems. This way you would have a properly set up modem but not any Ericsson applications that may try to access the com port along with NowSMS.
Bryce Norwood - NowSMS Support
Board Administrator
Username: Bryce

Post Number: 4904
Registered: 10-2002
Posted on Thursday, September 15, 2005 - 07:11 pm:   

This is weird. While it is most likely a USB driver issue, it seems unusual that it would lockup at this same spot every time ... even when you're tying in manually with HT.

Ashot's suggestion is a good one. And if you can get your hands on a serial cable instead, even better.

But I'm also thinking that maybe something has gone wrong in the phone itself. So you might want to try the usual suspects there ... remove the battery to perform a hard reset of the phone.

Also, the T68 has a "master reset" function in its menu, and I think it would be a good idea to try that as well.

Login Login / Register Logout Logout Search Last 30 Days Topics Topics