SMPP connection issue

SMPP connection issue SearchSearch

SMS & MMS Technical Forum » NowSMS Support - SMS Issues (Product Support Only) » SMPP connection issue « Previous || Next »
Author Message
Valentin Necula
New member
Username: Valentinkbt

Post Number: 1
Registered: 02-2020
Posted on Wednesday, February 26, 2020 - 12:28 pm:   

I have a small issue with SMPP client connections.
Automatically disconnect at a certain interval.
I am using v2020.01.15



Thanks,
Valentin
Des - NowSMS Support
Board Administrator
Username: Desosms

Post Number: 6109
Registered: 08-2008
Posted on Wednesday, February 26, 2020 - 03:20 pm:   

Hi Valentin,

Is NowSMS the SMPP client? Or is it the SMPP server, and you have an SMPP client that is getting disconnected?

The SMPP protocol is usually implemented in such a way that an idle/inactive connection is automatically disconnected if there is no activity for some period of time. This timeout varies greatly between different SMPP implementations, so NowSMS has configuration settings to control it.

An idle SMPP client is expected to send "enquire link" packets periodically if it wishes to keep the connection active. NowSMS refers to these as "keep-alive" packets.

When NowSMS is an SMPP client, this timeout is configured under the advanced settings for the SMSC connection:



The NowSMS default is to send "enquire link" every 58 seconds, which is slightly under 60 seconds, which is a frequent SMPP server timeout.

In the rare instance that you are working with a primitive SMPP server that does not understand "enquire link", use a value of 0 to stop NowSMS from sending it.

When NowSMS is in the role of SMPP server, it defaults to timing out clients after 120 seconds of inactivity. This value is configured under "SMPP Options" on the "Web" tab of the configuration:



--
Des
NowSMS Support
Valentin Necula
New member
Username: Valentinkbt

Post Number: 2
Registered: 02-2020
Posted on Thursday, February 27, 2020 - 11:09 am:   

Hi Des,

In my case, I use NowSMS as SMPP Server.
Those values ​​are set correctly from the beginning.
I've noticed a strange behavior. In low traffic conditions are ok/stable, when traffic is crowded, I don't have a stable connection.
I mention that I use the same GW's in other conditions, without NowSMS and works fine.
Des - NowSMS Support
Board Administrator
Username: Desosms

Post Number: 6113
Registered: 08-2008
Posted on Thursday, February 27, 2020 - 04:38 pm:   

Hi Valentin,

It is next to impossible to guess what the issue might be. How frequent are the disconnects?

The first thing I would suggest is checking CPU load in task manager to make sure that there is not a load problem.

Assuming there is not, it may be worth tweaking connection properties. If the client can use separate connections, it might become more reliable. Adjusting async window size properties on the client side might also help.

On the server side, it might help to enable async processing as described toward the last section of this doc: https://www.nowsms.com/smpp-async-mode
I would start by enabling for specific accounts to see if it makes a difference.


Des
NowSMS Support

Add Your Message Here, or click here to create a new discussion topic.
Post:
Bold text Italics Underline Create a hyperlink Insert a clipart image
Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Click here to create an account.
Username:
Password:
Options: Automatically activate URLs in message
Action:

Login Login / Register Logout Logout Search Last 30 Days Topics Topics