TC35i not receiving sms

TC35i not receiving sms SearchSearch

SMS & MMS Technical Forum » NowSMS Support - SMS Issues (Product Support Only) » Archive through June 02, 2006 » TC35i not receiving sms « Previous || Next »
Author Message
Ed
New member
Username: Edztra

Post Number: 1
Registered: 03-2006
Posted on Thursday, March 23, 2006 - 09:51 pm:   

Hi I'm trying to set up 2 way sms using a Siemens TC35i modem. I can send out messages ok but the modem receives no messages. Do I need to add some sort of initialization string somewhere?
What to do?
Bryce Norwood - NowSMS Support
Board Administrator
Username: Bryce

Post Number: 5720
Registered: 10-2002
Posted on Monday, March 27, 2006 - 08:20 pm:   

Hi Ed,

Enable the "SMSDEBUG.LOG" (on the "Serial #" page of the configuration dialog). And then let's take a look at that log file to see if it shows any signs of messages being received.

Some things to try ...

On the "SMSC" page, highlight the modem entry, and press "Properties".

Make sure "Receive SMS Messages" is checked.

Try different settings for the "SMS Message Storage" setting. Usually, with a dedicated modem device (as opposed to a phone acting as a modem), "Direct to Modem" is the best setting to use. Try the different settings to see if this makes any difference.

-bn
Ed
New member
Username: Edztra

Post Number: 2
Registered: 03-2006
Posted on Tuesday, March 28, 2006 - 01:11 pm:   

Thanks! The 'Direct to Modem' did the trick..
I have one other thing.

My simcard got blocked because the smsnow gateway enter the wrong password three times in a row. This was caused because I switched simcard with out changing the settings (i agree not very smart..) Is there any way for the system to stop trying to connect to the sim when wrong pin is entered..
Bryce Norwood - NowSMS Support
Board Administrator
Username: Bryce

Post Number: 5740
Registered: 10-2002
Posted on Tuesday, March 28, 2006 - 06:41 pm:   

Hi Ed,

Hmm ... that PIN issue is a difficult one.

I don't think we can stop the behaviour in the server. But we should make some changes in the configuration program.

Currently, if a modem is not responsive, we'll make several attempts to wake it up ... resending the PIN multiple times. So a single attempt to add a modem can result in the PIN being sent multiple times instead of only once.

We also don't tell you if there was a PIN related error.

So we will make modifications to report PIN related errors when adding/editing/testing a modem. And we will make sure to only send the possibly invalid PIN once.

Thanks for pointing out this problem.

-bn
Ed
New member
Username: Edztra

Post Number: 3
Registered: 03-2006
Posted on Tuesday, March 28, 2006 - 08:40 pm:   

cool.. Keep up the great work..

Login Login / Register Logout Logout Search Last 30 Days Topics Topics