Help! phone message sending Barred

Help! phone message sending Barred SearchSearch

SMS & MMS Technical Forum » NowSMS Support - SMS Issues (Product Support Only) » Archive through June 21, 2007 » Help! phone message sending Barred « Previous || Next »
Author Message
Jennymsc
New member
Username: Jennymsc

Post Number: 1
Registered: 03-2007
Posted on Friday, March 30, 2007 - 04:28 pm:   

Hi, I've notice that after i've connected my phone as modem for the NOW SMS/MMS gateway, after i setup the settings here and there, my phone can't send out any sms. This happens too when i disconnect my phone with PC. Please help. The SIM card is alright as it is working in other phone. I found out similar problem here http://support.nowsms.com/discus/messages/12/2284.h tml

Please help....
Bryce Norwood - NowSMS Support
Board Administrator
Username: Bryce

Post Number: 7037
Registered: 10-2002
Posted on Wednesday, April 04, 2007 - 08:26 pm:   

Hi,

Are you specifically getting an error code that indicates that you have been barred?

For the other thread that you are referencing, I don't think the user was even using NowSMS ... they were getting an error on their handset and posted here because they were lost.

If you're having a problem with NowSMS, I'd suggest enabling the SMSDEBUG.LOG and posting an excerpt here that shows you attempting to send a message.

-bn
Jennymsc
New member
Username: Jennymsc

Post Number: 2
Registered: 03-2007
Posted on Thursday, April 05, 2007 - 03:23 am:   

Hi, sorry for all the fuss, after researching and looking for the cause, it turned to be the SMS settings of the phone is changed to GPRS instead of GSM. I thought that could be the cause so I changed it back to GSM and everything works fine now.

However, I have a problem in receiving MMS with the NOWSMS/MMS gateway. I have followed the manual in configuring it. I've checked on the receive MMS into the directory of MMS-IN but there is nothing in the folder.
It is currently working fine in sending n receiving SMS and sending MMS.


p/s: I am using a Siemens MC35i modem.
Anyone could help? Thanks
Bryce Norwood - NowSMS Support
Board Administrator
Username: Bryce

Post Number: 7059
Registered: 10-2002
Posted on Thursday, April 05, 2007 - 06:18 pm:   

When an MMS is sent to the phone number of the modem, does the SMSIN-yyyymmdd.LOG record a binary SMS message being received?

If it does, then make sure the "MMS Receive" settings under the "Properties" for the modem in the SMSC list are set correctly. Enable the SMSDEBUG.LOG and MMSWAPDEBUG.LOG files ... send another MMS message to the modem, and post the SMSDEBUG.LOG and MMSWAPDEBUG.LOG files.

If it does not show a binary SMS message being received, then put the SIM card into a phone and verify that you can send and receive MMS using that SIM in a phone.

-bn
Jennymsc
New member
Username: Jennymsc

Post Number: 3
Registered: 03-2007
Posted on Friday, April 06, 2007 - 04:24 am:   

Yes, i do get a binary message like this ->
2007-04-01 17:26:17,36301,Binary, 0B05040B8423F00003A2030103062F1F2DB69181923746463246433242334142383332354241313132453133413332463541344446373145463231364200030B6A4A4D617869732057415000774D6178697320574150004D6178697320574150204750525300687474703A2F2F7761702E6D617869732E636F6D2E6D792F776D6C2F696E6465782E776D6C00,+0172983168

I think that the settings for the MMS are correct, but I've attached it so that u can take a look on it. I am from Malaysia btw.

the sim card is tested numerous time and it works perfectly with sending and receiving MMS with phone.

Where do I enable the sms debug Log and mms wap log?I am sorry to ask this, but i cant seem to find any option to enable this and I realized that i am missing these 2 files while everyone else in this forum is mentioning about them. MMS settings
Bryce Norwood - NowSMS Support
Board Administrator
Username: Bryce

Post Number: 7073
Registered: 10-2002
Posted on Monday, April 09, 2007 - 06:29 pm:   

Your settings look correct based upon the information that I've been able to find on the web.

The debug logs can be enabled via checkboxes on the "Serial #" tab (yes, that is not obvious).

Based upon what you have told me, it sounds like you are receiving the MMS notification over SMS ... but something is going wrong with the MMS retrieval.

So let's take a look at the SMSDEBUG.LOG and MMSWAPDEBUG.LOG.

-bn
Jennymsc
New member
Username: Jennymsc

Post Number: 4
Registered: 03-2007
Posted on Wednesday, April 11, 2007 - 03:58 pm:   

hey, it is so funny that now I don't even get a SMS in binary data. The thing is, I check on the Receive MMS in the MMS IN directory and the folder is always empty. anyways, i'll attach the smsdebug.log and the mmswapdebug.log. Thanks for the patience!
application/octet-streamsmsdebug
SMSDEBUG.LOG (3.3 k)

text/plainmmswapdebug
MMSWAPDEBUG.LOG (27.8 k)
Bryce Norwood - NowSMS Support
Board Administrator
Username: Bryce

Post Number: 7082
Registered: 10-2002
Posted on Wednesday, April 11, 2007 - 04:49 pm:   

If you're not getting the binary SMS any more, than this is a bad sign.

Try changing the "SMS Message Storage" setting to be "Direct to Modem", and let's see if this resolves the problem.

If it does not, try putting the SIM card from the modem into a phone ... verify that you can send and receive MMS using the SIM in a phone. Then put the SIM back into a modem.

That binary SMS message is what triggers the MMS reception process ... so we need that, otherwise there is no MMS to receive.

-bn

Login Login / Register Logout Logout Search Last 30 Days Topics Topics