No action taken (execute a exe with SMS as commandline param)upon r...

No action taken (execute a exe with SMS as commandline param)upon r... SearchSearch

SMS & MMS Technical Forum » NowSMS Support - SMS Issues (Product Support Only) » Archive through March 09, 2004 » No action taken (execute a exe with SMS as commandline param)upon receiving SMS « Previous || Next »
Author Message
kuo ren
Unregistered guest
Posted on Friday, January 09, 2004 - 12:58 am:   

Please help me with this problem.
I have configured the 2-way-sms config page to execute an application that I write with call phone number and SMS content passed in to the app as command line params. The actually configuration text is follows:
* C:\SmsProcessor.exe @@SENDER@@ @@FULLSMS@@

I also enabled debug logging for nowSms gateway.

When I send the SMS to Now SMS gateway, the debug logs (shortened)looks like bellow:

Executing C:\SmsProcessor.exe +1999345678 smsbody

However, the program SmsProcessor.exe is not run. Could anybody help me with this subtle problem? Thanks alot!

Kuo
Bryce Norwood - NowSMS Support
Board Administrator
Username: Bryce

Post Number: 1560
Registered: 10-2002
Posted on Friday, January 09, 2004 - 03:31 pm:   

Kuo,

What happens if you send two (or more) messages in.

I'm wondering if they are processed in quick succession ... with two "Executing ..." commands appearing in the debug log, or if it takes as much as 5 minutes between them.

It looks like NowSMS is running the program. If an error occurred trying to run the program, I would expect an error to be returned to the sender via SMS.

The reason that I ask about sending multiple messages, and whether or not there is a 5 minute delay, is because NowSMS will wait up to 5 minutes for an executable program to finish via the "2-way" facility. I'm wondering if for some reason the program is running, but it is just not running correctly for some reason. (I'd suggest simplifying the program for debugging purposes in that case.)

-bn
kuo ren
Unregistered guest
Posted on Friday, January 09, 2004 - 08:42 pm:   

Thanks Bryce, actually the software is run and worked but it output the log file in the system32 directory instead of the same directory as the exe which is a surprise to me. Thanks again for you help.

Kuo

Login Login / Register Logout Logout Search Last 30 Days Topics Topics