“no internet call services”

“no internet call services” SearchSearch

SMS & MMS Technical Forum » NowSMS Support - SMS Issues (Product Support Only) » Archive through June 24, 2009 » “no internet call services” « Previous || Next »
Author Message
Nikola Nikodimov
New member
Username: Gsming

Post Number: 1
Registered: 06-2009
Posted on Wednesday, June 24, 2009 - 05:41 am:   

I try to send XML for setup VOIP service in Nokia E51.
Phone says “no internet call services” until I touch the VoIP profile manually.

Is the problem really from NowSMS?

Here is discussion of this problem. http://discussion.forum.nokia.com/forum/showthread.php?t=105398

Any help with this problem is highly appreciated.
Nikola Nikodimov
New member
Username: Gsming

Post Number: 2
Registered: 06-2009
Posted on Wednesday, June 24, 2009 - 09:59 am:   

If the key point was what is said in the subject, then the likely reason is that the APPREF reference - selection of the SIP profile in VoIP profile with "<parm name="TO-APPREF" value="link to SIP"/>" is not compiled correctly i.e. in this detail the used xml2wbxml tool is not compatible with the new referencing way used by S60 clients.
This is the bug in nowSMS? Have any comments?
Bryce Norwood - NowSMS Support
Board Administrator
Username: Bryce

Post Number: 7809
Registered: 10-2002
Posted on Wednesday, June 24, 2009 - 01:56 pm:   

Try changing the header to:

<wap-provisioningdoc version="1.2">

NowSMS bases its encoding on the version number in the header.

In 1.1, "TO-APPREF" is encoded as a literal.

In 1.2, "TO-APPREF" is encoded using a short code defined in the 1.2 version of the OMA Provisioning Content spec.

I also seem to remember a problem with some Nokia provisioning, where they would not accept 1.2 in the version header, but they expected the encoding from the 1.2 spec to be used. In that case, leave the version as 1.1, but put UseOMAProvCont12=Yes under the [SMSGW] header of SMSGW.INI.

I'd recommend first trying to change the version number in your XML, as that would be the correct way to handle it.

-bn
Bryce Norwood - NowSMS Support
Board Administrator
Username: Bryce

Post Number: 7810
Registered: 10-2002
Posted on Wednesday, June 24, 2009 - 02:00 pm:   

Another thing to try ...

OTAUseWBXMLStringTable=No under the [SMSGW] header of SMSGW.INI will also effect the WBXML encoding of the value associated with your "APPREF" and "TO-APPREF" settings.

This setting will make the resulting WBXML larger, so it is not recommended unless it resolves a specific problem.

-bn
Nikola Nikodimov
New member
Username: Gsming

Post Number: 3
Registered: 06-2009
Posted on Wednesday, June 24, 2009 - 03:45 pm:   

All working fine with UseOMAProvCont12=Yes.

THANKS!!!

Login Login / Register Logout Logout Search Last 30 Days Topics Topics