Shift Tables

Shift Tables SearchSearch

SMS & MMS Technical Forum » NowSMS Support - SMS Issues (Product Support Only) » Archive through May 20, 2013 » Shift Tables « Previous || Next »
Author Message
Marcos
New member
Username: Marcosdoni

Post Number: 1
Registered: 12-2012
Posted on Tuesday, December 11, 2012 - 10:45 am:   

I added the line in SMSGW.INI as follows

[SMSGW]
ShiftTables = 3

But I'm still having problems. Messages arrives with character "¿" or "Ã" © instead "é"...

I dont know more what to do...

My language is: portuguese.


I already used parameter &charset=iso-8859-1...
Des - NowSMS Support
Board Administrator
Username: Desosms

Post Number: 4238
Registered: 08-2008
Posted on Tuesday, December 11, 2012 - 03:19 pm:   

"é" is part of the standard GSM character set. There is no reason to be using a shift table to send this character.

Characters that are part of the standard GSM character set can be found in a table in the following article: http://www.nowsms.com/long-sms-text-messages-and-the-160-character-limit

How exactly are you submitting the message to NowSMS? Does it work ok if you use the built-in web form?

It is important to always try the built-in web form first in cases like this ... if the same characters work fine from the built-in web form, this tells us whether the issue is on the input or output side.

I am assuming that in your case the built-in web form also fails to send this character. In that case, what is the type of SMSC connection? If it is SMPP, it might be necessary to try a different character set (try iso-8859-1 first, then if that fails, try GSM/IA5). To avoid confusion, one clarification ... I am referring to the character set configured under Advanced Settings for the SMPP connection, not a character set in an input HTTP URL.

Also, for now, remove the ShiftTables setting ... if the provider does not support shift tables this may cause other issues.

--
Des
NowSMS Support
Marcos
New member
Username: Marcosdoni

Post Number: 2
Registered: 12-2012
Posted on Tuesday, December 11, 2012 - 09:49 pm:   

Im submitting something like http://server:8800/?PhoneNumber=xxxxxxxxxx&text=teste+é

But I also tried web form built-in and Im getting same problem... SMSC Connection is a GSM Modem and there is no advanced configuration on it...

Any suggestion?
Des - NowSMS Support
Board Administrator
Username: Desosms

Post Number: 4241
Registered: 08-2008
Posted on Wednesday, December 12, 2012 - 02:29 pm:   

Hi Marcos,

Please try the web form again. Type "é" directly into the message text. It should be able to send the "é" character via a GSM modem with no configuration required. If it does not, what character is received?

I am assuming that this test works.

The NowSMS web form is configured to submit text using the UTF-8 character set. If you are using a different character set, then it is necessary to specify the character set in the URL. For most European languages, that would be &charset=iso-8859-1 ... or http://server:8800/?PhoneNumber=xxxxxxxxxx&text=teste+é&charset=iso-8859-1

If you are unable to resolve the issue, I would like to see an SMSDEBUG.LOG that would show me more details about your attempts. The SMSDEBUG.LOG is enabled via a checkbox option on the "Serial #" page.

After enabling SMSDEBUG.LOG, send your test message 3 times. Once from the built-in web form, then from your HTTP URL submission, with and without &charset=iso-8859-1

After this, post your SMSDEBUG.LOG as an attachment in reply here, or e-mail it to nowsms@nowsms.com with Attention: Des in the subject line of the e-mail. If you send it via e-mail, please post a quick reply here also to tell me to look for the e-mail.

--
Des
NowSMS Support
Marcos
New member
Username: Marcosdoni

Post Number: 3
Registered: 12-2012
Posted on Wednesday, December 12, 2012 - 05:37 pm:   

after trying unsuccessfully again ... even after changing charset parameter... Im sending the log file
application/octet-streamSMSDebug
SMSDEBUG.LOG (9.3 k)
Marcos
New member
Username: Marcosdoni

Post Number: 4
Registered: 12-2012
Posted on Wednesday, December 12, 2012 - 05:42 pm:   

Characters arrive: é or ¿ ... depending of charset parameter
Des - NowSMS Support
Board Administrator
Username: Desosms

Post Number: 4242
Registered: 08-2008
Posted on Wednesday, December 12, 2012 - 06:45 pm:   

The text of your submission is in UTF-8 format already. There is NO reason to add the &charset=iso-8859-1 parameter in your case.

When you submit the message without the charset parameter, I can see that the "é" is being correctly encoded. (It is being sent out as GSM character 5).

"¿" is GSM character 0x60. So it makes no sense that this would appear instead of "é".

Is the receiving device an actual phone or something else?

Is the modem on a the same network as the receiving device?

If you move the SIM card from the modem to a phone can you use the SMS client in the phone to send the "é" character to the same receiving device?

I wish I had an explanation for you ... the message in the case of no charset parameter appears to be encoded correctly.

--
Des
NowSMS Support
Marcos
New member
Username: Marcosdoni

Post Number: 5
Registered: 12-2012
Posted on Wednesday, December 12, 2012 - 07:15 pm:   

Is the receiving device an actual phone or something else?
Samsung Galaxy S II

Is the modem on a the same network as the receiving device?
Yes

If you move the SIM card from the modem to a phone can you use the SMS client in the phone to send the "é" character to the same receiving device?
I'll try that
Marcos
New member
Username: Marcosdoni

Post Number: 6
Registered: 12-2012
Posted on Wednesday, December 12, 2012 - 07:27 pm:   

Sending from modem application occurs same problem... so NowSMS is ok...

Login Login / Register Logout Logout Search Last 30 Days Topics Topics