Inbox folder empty but SMS received fine

Inbox folder empty but SMS received fine SearchSearch

SMS & MMS Technical Forum » NowSMS Support - SMS Issues (Product Support Only) » Archive through November 14, 2013 » Inbox folder empty but SMS received fine « Previous || Next »
Author Message
Davide Ghirardini
New member
Username: Ghironet

Post Number: 8
Registered: 08-2013
Posted on Friday, September 06, 2013 - 06:05 pm:   

Hi Support,
strange issue since this morninng I can't see any SMS IN messages in the inbox web folder. The connection to the modem is working fine. I can see the incoming messages in the SMSIN logs only. Do you have an idea about that? I didn't change anything in the configuration...

Thank you.

Davide.
Des - NowSMS Support
Board Administrator
Username: Desosms

Post Number: 4639
Registered: 08-2008
Posted on Friday, September 06, 2013 - 07:47 pm:   

Hi Davide,

Are settings configured to route received messages to the same user account as you are logging in to the web interface as?

--
Des
NowSMS Support
Davide Ghirardini
New member
Username: Ghironet

Post Number: 9
Registered: 08-2013
Posted on Friday, September 06, 2013 - 08:02 pm:   

Actually not, did you remember the configuration you seggested to me in order to forward the incoming messages and to keep it in the inbox folder?

Davide
Des - NowSMS Support
Board Administrator
Username: Desosms

Post Number: 4640
Registered: 08-2008
Posted on Friday, September 06, 2013 - 08:55 pm:   

I'd double check the settings to make sure something didn't change:

http://support.nowsms.com/discus/messages/1/71888.html

I assume that the 2-way commands are still seeing the messages correctly. And I assume that you are logging in to the web interface with the same user account that has been configured to receive messages.

I assume you haven't experimented with connecting to that user account via SMPP or POP3 ... that would remove messages.

I'd probably need to see the configuration file again.

That said, we did fix the issue where DuplicateUserMessagesFor2Way=Yes didn't work in conjunction with the "Route SMS to local user" setting.

So you could update and switch over to that setting. (Blank out the setting for the user account under "Recipient address(es) to route to this user". Put the "Route SMS to local user" setting back in the modem definition.) The update is at http://www.nowsms.com/download/nowsms20130830.zip.

--
Des
NowSMS Support
Davide Ghirardini
New member
Username: Ghironet

Post Number: 10
Registered: 08-2013
Posted on Saturday, September 07, 2013 - 11:43 am:   

Hi Des,
you are assuming all right, see the conf file below:

[Inbound SMS Routing]
[Modem - COM5:]
PhoneNumber=+123456
ReceiveSMS=Yes
ReceiveMMS=No
[SMSGW]
Modem1=COM5:
WebAuth=Yes
WebMenu=Yes
WebPort=8800
SeparateUserQueues=No
ReceiveSMS=Yes
ReceiveMMS=No
PHPEnable=No
PHPAllowRemote=No
ReceiveSMSCommand1=* http://127.0.0.1:8800/?user=username&password=password&phonenumber=54321&text=@@SENDER@@/@@FULLSMS@@ No
ReceiveSMSCharset=utf-8
DuplicateUserMessagesFor2Way=Yes

Regarding the new version you are suggesting (nowsms20130830) I hope will works fine with my GSM modem because the nowsms20130731 is really slow to send sms...

I'll let you know if it works.

Thank you.

Davide.
Des - NowSMS Support
Board Administrator
Username: Desosms

Post Number: 4641
Registered: 08-2008
Posted on Saturday, September 07, 2013 - 01:56 pm:   

Hi Davide,

The [Inbound SMS Routing] section is blank ... that is why it is not working. Without that setting, there is no instruction to route the received SMS message to a user inbox. That entry is set when you configure "Recipient address(es) to route to this user" for a user account. (Like I suggested in the earlier e-mail. It would not be used if you go back to using the "Route SMS to local user" setting in the update.)

You will not see any difference in speed. Modems tend to be slow and take a number of seconds to send out a message. Signal strength (i.e., number of bars) is a major consideration, and some modems are just faster than others.

One tip ... you can try adjusting the "SMS Access" setting. A non-default setting may offer better performance. The GPRS setting (it doesn't really limit to GPRS, it means packet switched network) offers the best theoretical performance ... but many operators have this interface disabled ... you just have to try it. For situations where the operator has that interface disabled, you may get better performance with the GSM setting (again it doesn't really limit to GSM, it just means the circuit switched side of the network) because the modem might be trying the packet switched interface first then falling back to the circuit side when it fails ... in this case the GSM setting may improve performance .... you just have to try it.

--
Des
NowSMS Support
Davide Ghirardini
New member
Username: Ghironet

Post Number: 11
Registered: 08-2013
Posted on Sunday, September 08, 2013 - 02:29 pm:   

Hi Des,
with the last version you suggested to me (30082013) my GSM modem is really slow and sometimes is not able to send sms. I tried both configuration (GSM and GPRS) but is not working fine. The only NOWSMS version that is very fast with my modem is the 2012.06.28

Do you have some clarifications about that?

Thank you.

Davide.
Des - NowSMS Support
Board Administrator
Username: Desosms

Post Number: 4642
Registered: 08-2008
Posted on Monday, September 09, 2013 - 01:21 pm:   

Hi Davide,

What model is the modem?

What is the exact speed difference to which you are referring? (We need to quantify the difference. Time stamps from SMSOUT logs would be most helpful.)

Does re-installing the 2012.06.28 version restore the speed? (Need to determine if the problem is truly version related or just coincidence.)

Trial version or purchased license?

If there really is a change in performance that is modem related, there is only one setting that comes to mind. Try adding ModemMaxBytesPerSend=16 to the [SMSGW] section of SMSGW.INI. This restores a default setting from the 2012.06.28 version which has since been changed in the newer versions.

--
Des
NowSMS Support
Davide Ghirardini
New member
Username: Ghironet

Post Number: 12
Registered: 08-2013
Posted on Wednesday, September 11, 2013 - 08:40 am:   

Hi Des,
sorry for my late reply. The modem is an internet key (Onda Telecomunication MT503HSA). Yes installing the 2012.06.28 version I fixed the issue. Trial version in order to test the software before the purchase.

I'll add the "ModemMaxBytesPerSend=16" string to the SMSGW.INI conf file. I'll do some test and I'll let you know.

Thanks,

Davide.
Davide Ghirardini
New member
Username: Ghironet

Post Number: 13
Registered: 08-2013
Posted on Wednesday, September 11, 2013 - 10:47 am:   

Hi Des,
using the last version of nowsms you suggested the "DuplicateUserMessagesFor2Way=Yes " dosn't work. I don't know why, probably a software bug, if I configure the web sms out function only the speed issue is fixed. If I configure some more functions like 2 way the sending SMS function becoming very slow...

Davide.
Des - NowSMS Support
Board Administrator
Username: Desosms

Post Number: 4652
Registered: 08-2008
Posted on Wednesday, September 11, 2013 - 02:24 pm:   

Hi Davide,

I'm still trying to get an idea of "how slow is slow".

You are saying that SMS sending is normal until you configure a 2-way command, and then it becomes slow sending?

Is that correct?

There's no logical connection between the activities. Some modems do get a little confused when receiving messages (independent of whether a 2-way command is configured), and they return errors when sending while a message is coming in ... which slows things down a little bit.

I guess I'd need to see an SMSDEBUG.LOG in order to understand what is occurring. Enable that and repeat the problem scenario. You can e-mail the SMSDEBUG.LOG to nowsms@nowsms.com. Put Attention: Des in the subject line, and post a reply here to let me know you've sent it, so that I know to look for it.

I'm also confused about "DuplicateUserMessagesFor2Way=Yes" not working. Pre-2013.08.30 version, this setting did not work with "Route SMS to local user" setting, but required a work-around. I do not see any problems with this setting and the 2013.08.30 version. When you say it does not work, what is happening?

--
Des
NowSMS Support
Davide Ghirardini
New member
Username: Ghironet

Post Number: 14
Registered: 08-2013
Posted on Wednesday, September 11, 2013 - 08:10 pm:   

Hi Des, I'll setup the problem scenario again for you during the weekend and I'll let you know.

Thank you.

Davide.
Davide Ghirardini
New member
Username: Ghironet

Post Number: 15
Registered: 08-2013
Posted on Wednesday, September 18, 2013 - 10:40 am:   

Hi Des,
I definetly fixed the issue. I formatted the PC and performed a new installation of the 20130830 version directly without upgrading from the 2012 version.

Now the software seems ok.

Thank you very much for your help!

Davide.

Login Login / Register Logout Logout Search Last 30 Days Topics Topics