Auto Logout

Auto Logout SearchSearch

SMS & MMS Technical Forum » NowSMS NextGen (Product Support Only) » Auto Logout « Previous || Next »
Author Message
Pancho
New member
Username: Pancho

Post Number: 8
Registered: 09-2005
Posted on Thursday, November 12, 2020 - 04:14 am:   

Hello,

After installing the app and managed to add SMSC. All of the sudden, I was logged out automatically. I am getting error "Can't open page localhost:8800/ADMIN/Server". I tried reinstalling the app but I am still getting the same problem.

The problem is after I login. Then, I click on any of the menu it will send me back to
the login page again.


Regards,
Pancho
Pancho
New member
Username: Pancho

Post Number: 9
Registered: 09-2005
Posted on Thursday, November 12, 2020 - 08:41 am:   

Hello,

Below is the error logs.

{"share_with_app_devs":0,"app_version":"","bug_type":"309","timestamp":"2020-11-12 17:39:17.00 +0800","os_version":"Mac OS X 10.15.6 (19G2021)","slice_uuid":"e6689e88-e04c-3497-a111-5a6d45616b34","is_first_party":1,"build_version":"","incident_id":"4CA1C581-42D7-418E-A784-B83A1FD39B97","app_n ame":"NowSMS","name":"NowSMS"}
{
"uptime" : 29000,
"procLaunch" : "2020-11-12 17:39:12.8398 +0800",
"procRole" : "Unspecified",
"exception" : {
"type" : "EXC_CRASH",
"signal" : "SIGABRT",
"codes" : "0x0000000000000000, 0x0000000000000000"
},
"userID" : 0,
"modelCode" : "MacPro6,1",
"coalitionID" : 4279,
"osVersion" : {
"train" : "Mac OS X 10.15.6",
"build" : "19G2021",
"releaseType" : ""
},
"captureTime" : "2020-11-12 17:39:17.2584 +0800",
"incident" : "4CA1C581-42D7-418E-A784-B83A1FD39B97",
"pid" : 11314,
"cpuType" : "X86-64",
"procName" : "NowSMS",
"procPath" : "\/usr\/local\/bin\/NowSMS",
"parentProc" : "NowSMS",
"parentPid" : 10813,
"coalitionName" : "com.nowsms.nowsms",
"crashReporterKey" : "9D54A93F-B102-7FF3-6504-C83F154A9B11",
"responsiblePid" : 10813,
"responsibleProc" : "NowSMS",
"sip" : "enabled",
"is_corpse" : 1,
"asi" : ["stack buffer overflow"],
"extMods" : {"caller":{"thread_create":0,"thread_set_state":0,"task_for_pid":0},"system":{"thread_create":0,"thread_set_state":0,"task_for_pid":126279},"targeted":{"thread_ create":0,"thread_set_state":0,"task_for_pid":0},"warnings":0},
"threads" : [{"id":740712,"frames":[[0,14466],[1,1175539],[1,2539271],[2,109769]]},{"id":740764,"frames":[[0,29654],[3,24841],[3,7051]]},{"id":740765,"frames":[[0,14466],[1 ,1175539],[1,1293200],[3,24841],[3,7051]]},{"id":740766,"frames":[[0,14466],[1,1175539],[1,1375822],[3,24841],[3,7051]]},{"id":740767,"frames":[[0,14466],[1,117 5539],[1,1303572],[3,24841],[3,7051]]},{"id":740768,"frames":[[0,14466],[1,1174194],[1,44697],[1,512021],[3,24841],[3,7051]]},{"id":740769,"frames":[[0,14466],[ 1,1175539],[1,477472],[3,24841],[3,7051]]},{"id":740770,"frames":[[0,14466],[1,1175539],[1,477472],[3,24841],[3,7051]]},{"id":740771,"frames":[[0,14466],[1,1175 539],[1,511590],[3,24841],[3,7051]]},{"id":740772,"frames":[[0,14166],[4,490980],[1,1552410],[3,24841],[3,7051]]},{"id":740773,"frames":[[0,14466],[1,1174194],[ 1,44697],[1,270533],[3,24841],[3,7051]]},{"id":740774,"frames":[[0,14466],[1,1174194],[1,44697],[1,271520],[3,24841],[3,7051]]},{"id":740775,"frames":[[0,14166] ,[4,490980],[1,1581240],[3,24841],[3,7051]]},{"id":740776,"frames":[[0,14466],[1,1174194],[1,44697],[1,1581525],[3,24841],[3,7051]]},{"id":740777,"frames":[[0,2 9654],[1,2068896],[1,258175],[3,24841],[3,7051]]},{"id":740778,"frames":[[0,29498],[4,522402],[4,367995],[1,277528],[5,6655295901103053916]],"triggered":true},{ "id":740779,"frames":[[0,14466],[1,1174194],[1,510993],[3,24841],[3,7051]]},{"id":740780,"frames":[[0,14466],[1,1174194],[1,44697],[1,1874615],[3,24841],[3,7051 ]]},{"id":740838,"frames":[[0,14466],[1,1175539],[1,2024150],[3,24841],[3,7051]]},{"id":740845,"frames":[[0,14466],[1,1174194],[1,44697],[1,2174008],[1,2248110] ,[1,2349198],[1,2526944],[3,24841],[3,7051]]},{"id":740867,"frames":[[0,14466],[1,1175539],[1,2024150],[3,24841],[3,7051]]}],
"threadState" : {
"r13" : 0,
"rax" : 0,
"rflags" : 582,
"cpu" : 0,
"r14" : 6,
"rsi" : 6,
"r8" : 0,
"cr2" : 4332589056,
"rdx" : 0,
"r10" : 123145413865472,
"r9" : 0,
"r15" : 22,
"rbx" : 123145413865472,
"trap" : 133,
"err" : 33554760,
"r11" : 582,
"rip" : 140734956278586,
"rbp" : 123145413725344,
"rsp" : 123145413725304,
"r12" : 10243,
"rcx" : 123145413725304,
"flavor" : "x86_THREAD_STATE",
"rdi" : 10243
},
"usedImages" : [
[
"2b6311e6-6240-3ef7-8c87-475b66f7452c",
140734956249088,
"P"
],
[
"e6689e88-e04c-3497-a111-5a6d45616b34",
4314558464,
"P"
],
[
"789a18c2-8ac7-3c88-813d-cd674376585d",
140734954827776,
"P"
],
[
"62cb1a98-0b8f-31e7-a02b-a1139927f61d",
140734957043712,
"P"
],
[
"bbded5e6-a646-3eed-b33a-91e4331ea063",
140734955261952,
"P"
],
[
"00000000-0000-0000-0000-000000000000",
0,
"A"
]
],
"legacyInfo" : {
"imageExtraInfo" : [
{
"size" : 184320,
"arch" : "x86_64",
"path" : "\/usr\/lib\/system\/libsystem_kernel.dylib",
"name" : "libsystem_kernel.dylib"
},
{
"size" : 12173312,
"arch" : "x86_64",
"path" : "\/usr\/local\/bin\/NowSMS",
"name" : "NowSMS"
},
{
"size" : 225280,
"arch" : "x86_64",
"path" : "\/usr\/lib\/system\/libdyld.dylib",
"name" : "libdyld.dylib"
},
{
"size" : 45056,
"arch" : "x86_64",
"path" : "\/usr\/lib\/system\/libsystem_pthread.dylib",
"name" : "libsystem_pthread.dylib"
},
{
"size" : 557056,
"arch" : "x86_64",
"path" : "\/usr\/lib\/system\/libsystem_c.dylib",
"name" : "libsystem_c.dylib"
},
{
"size" : 0
}
],
"threadTriggered" : {
"index" : 15
}
}
}
Pancho
New member
Username: Pancho

Post Number: 10
Registered: 09-2005
Posted on Thursday, November 12, 2020 - 01:19 pm:   

Hi,

After being idle for some time. The service shuts down by itself, is it possible to have the service running persistently?

Thank you in advance.


Regards,
Pancho
Pancho
New member
Username: Pancho

Post Number: 11
Registered: 09-2005
Posted on Thursday, November 12, 2020 - 01:45 pm:   

Hi,

This sudden logging me out happens the moment I added my 2nd SMSC. Not sure if this information will help.

Regards,
Pancho
Bryce Norwood - NowSMS Support
Board Administrator
Username: Bryce

Post Number: 8369
Registered: 10-2002
Posted on Friday, November 13, 2020 - 01:47 pm:   

Hi Pancho,

We need to enable the SMSDEBUG.LOG to get an idea of what is going wrong. And it would be helpful to see the SMSGW.INI configuration file.

Unfortunately, as NowSMS seems to be in a crash loop, it may be difficult to enable the debug log or access this configuration file..

Open a terminal window.

Type the following command to access the NowSMS configuration files:

cd /var/lib/nowsms

The primary NowSMS configuration file is located in this directory. We want to add a setting to enable the debug log to this configuration file. Use the following command to load a primitive editor that will allow us to edit the file.

sudo nano SMSGW.INI

Use the arrow keys to scroll to the line in the file after [SMSGW]

Press Enter to add a blank line, then use the up arrow to move the cursor to that new blank line. Type Debug=Yes into that black line.

Press Control-X, and answer Y (yes) to save the change.

Switch to a different window, and confirm that you are still having a problem where NowSMS keeps returning to the login screen.

If you are only getting connection errors (no login option), use the following commands to restart the NowSMS service:

sudo launchctl unload /Library/LaunchDaemons/com.nowsms.nowsms.plist
sudo launchctl load /Library/LaunchDaemons/com.nowsms.nowsms.plist

After seeing the problem repeat a few times, let's copy the debug log and SMSGW.INI file to somewhere that you can easily access them to share with us. The easiest way to do this is probably to copy them to your desktop. Back in the terminal window, type the following commands, substituting your Mac login account name for name:

cp SMSGW.INI /Users/name/Desktop
cp SMSDEBUG.BAK /Users/name/Desktop
cp SMSDEBUG.LOG /Users/name/Desktop

These files should now be copied to your desktop. Upload these files as attachments in a reply here or e-mail to nowsms@nowsms.com with Attention: Bryce in the subject line.

Regards,

Bryce Norwood
NowSMS Support
Bryce Norwood - NowSMS Support
Board Administrator
Username: Bryce

Post Number: 8371
Registered: 10-2002
Posted on Friday, November 13, 2020 - 03:18 pm:   

Hi Pancho,

One more thought ...

After looking through the crash report that you included above, we have a potential theory.

Try downloading the updated version at https://www.nowsms.com/download/macos/nowsms.tar.gz ... Extract and run NowSMSInstall, and choose the update option.

There's a small chance that this might resolve the problem ... otherwise follow the steps listed in the previous message.

Regards,

Bryce Norwood
NowSMS Support
Pancho
New member
Username: Pancho

Post Number: 12
Registered: 09-2005
Posted on Friday, November 13, 2020 - 11:35 pm:   

Hi Bryce,

Thank you for getting back to me. I already sent you the email with files you have requested.

I updated the version to .11 but, I am still getting the same result. Also, after the service crashed for some reason I have to keep on reinstalling the update.

I hope the files will be able to help you.

Regards,
Pancho
Bryce Norwood - NowSMS Support
Board Administrator
Username: Bryce

Post Number: 8372
Registered: 10-2002
Posted on Saturday, November 14, 2020 - 01:24 pm:   

Hi Pancho,

I think we identified the problem, and posted an update (which should identify itself as 2020.11.14. The issue appears to be unrelated to the number of SMSC connections (in this case USB modems), but rather a coding mistake related to a large number of pending received messages.

If the problem persists, please send SMSDEBUG.BAK.

Regards,

Bryce
NowSMS Support
Pancho
New member
Username: Pancho

Post Number: 13
Registered: 09-2005
Posted on Sunday, November 15, 2020 - 01:33 pm:   

Hi Bryce,

I think the app has a problem running. I can't install the app and the service isn't running when I am trying update to 2020.11.14. It just hangs on the page that says, Please wait This page will automatically refresh when the operation is complete.

Also tried doing fresh install but its the same problem. Perhaps I am doing something wrong. Can you give me a guide how do I re-install the app?

Thank you.

Regards,
Pancho
Pancho
New member
Username: Pancho

Post Number: 14
Registered: 09-2005
Posted on Sunday, November 15, 2020 - 02:44 pm:   

Hi Bryce,

I completely did the fresh install and updated it to the current version. I also sent you an email along with the debug file. I am having problems on my 2nd GSM modem.

Thank you.

Regards,
Pancho
Pancho
New member
Username: Pancho

Post Number: 15
Registered: 09-2005
Posted on Sunday, November 15, 2020 - 02:58 pm:   

Hi Bryce,

I tried adding the 2nd modem manually to the SMSGW.INI file. When I refresh the page I can see it was added in the GUI under SMSC Connections then it crashed just like before.

So, I reverted it to the original SMSGW.INI file which only contains 1 GSM modem and it does not crash anymore.

Hope this info helps.

Regards,
Pancho
Bryce Norwood - NowSMS Support
Board Administrator
Username: Bryce

Post Number: 8373
Registered: 10-2002
Posted on Sunday, November 15, 2020 - 09:10 pm:   

Hi Pancho,

When it is crashing is there an SMSDEBUG.BAK file? That is what we would really like to see. (You've sent SMSDEBUG.LOG)

My teammates will be studying this in more detail tomorrow, but looking through some past incident reports, I see a setting that might be helpful. Try editing the SMSGW.INI manually, and in the section for the modem that seems to be triggering the problem, add:

ForceCMGR=Yes

I suspect this setting will bypass the logic that is causing the crash.


quote:

It just hangs on the page that says, Please wait This page will automatically refresh when the operation is complete.




If this happens, try going to localhost:8800 directly. It sounds like it is still crashing.

The following terminal command also can be helpful if there is a crash loop:

killall 9 NowSMS

Regards,

Bryce Norwood
NowSMS Support
Pancho
New member
Username: Pancho

Post Number: 16
Registered: 09-2005
Posted on Monday, November 16, 2020 - 01:43 am:   

Hi Bryce,

I tried the killall 9 NowSMS command but it says "No matching processes belonging to you were found". The app kept on sending me back to index after login. Hopefully, the attached debug file will help your team.

Thank you.

Regards,
Pancho




application/octet-streamdebug file
SMSDEBUG.BAK (70.4 k)
Pancho
New member
Username: Pancho

Post Number: 17
Registered: 09-2005
Posted on Monday, November 16, 2020 - 01:47 am:   

Hi Bryce,

I forgot to mention that I added the line ForceCMGR=Yes, but it still crashes.

Regards,
Pancho
Pancho
New member
Username: Pancho

Post Number: 18
Registered: 09-2005
Posted on Monday, November 16, 2020 - 02:01 am:   

Hi Bryce,

I reinstalled the app again and removed the 2nd SMSC connection. Everything works fine but, every time I added the 2nd SMSC the crash comes back again. Hopefully, this info will help your team.

Regards,
Pancho
Bryce Norwood - NowSMS Support
Board Administrator
Username: Bryce

Post Number: 8374
Registered: 10-2002
Posted on Monday, November 16, 2020 - 05:16 pm:   

Hi Pancho,

Thanks for your patience.

We're beginning to think that there is something about this particular modem that is triggering a fatal crash.

In the first log that you sent, I could clearly see a logic error in NowSMS. Subsequent logs confirm that this logic error was fixed, but the crash remains.

We have a new theory based on the original crash report. Another update has been posted which includes a slight modification to our modem handler, which we hope will fix the problem.

What is the manufacturer and model of this modem? Is there any special USB driver that needed to be installed on the Mac to enable it?

Regards,

Bryce
NowSMS Support
Pancho
New member
Username: Pancho

Post Number: 19
Registered: 09-2005
Posted on Monday, November 16, 2020 - 11:44 pm:   

Hi Bryce,

I am using Teltonika GSM modem. There is a driver for windows but for Mac there's none, maybe the driver is built-in already.

Do I need to reinstall the app or is there a way that I can update without reinstalling ?

Thank you.

Regards,
Pancho
Des - NowSMS Support
Board Administrator
Username: Desosms

Post Number: 6200
Registered: 08-2008
Posted on Tuesday, November 17, 2020 - 12:23 am:   

If the web interface is stable, the easiest way to update is the button that appears under Admin/System Configuration.

As that does not seem to be the case, I’d recommend this:

Download and extract updated NowSMSInstall

Run ./NowSMSInstall and select option to remove. (This will not delete configuration data.)

Run ./NowSMSInstall again and select the option to install.

Regards,

Des
NowSMS Support
Pancho
New member
Username: Pancho

Post Number: 20
Registered: 09-2005
Posted on Tuesday, November 17, 2020 - 12:49 am:   

Hi Bryce,

I already applied the update. I just noticed the 2nd SMSC Connections will appear in the choices after the modem is connected for several hours. Also did a quick check on the log file and noticed that the 2nd modem was detected with no error which makes me wonder why the app not showing the 2nd modem in SMSC connections. Then I tried manually adding the 2nd modem details in SMSGW.INI, the crash comes back. By the way, I am using the same brand for both GSM modems.

I will update you if the crash still happens once the 2nd modem appears in the choices in SMSC Connections. Hopefully this info will help you and your team.

Thank you.

Regards,
Pancho
Pancho
New member
Username: Pancho

Post Number: 21
Registered: 09-2005
Posted on Tuesday, November 17, 2020 - 09:35 am:   

Hi Bryce,

I got a new GSM modem (wavecom fastrack). Does the app support this modem because I cannot see it in the SMSC Connection whenever I am trying to add a new modem. I can see these lines in the log file. It looks okay.

18:31:55:671 [230858752] m=101,0 ModemScanForModems: Opened device tty.usbserial-10
18:31:55:794 [230858752] m=101,0 SendModemCommand: ATE0V1

18:31:55:809 [230858752] m=101,0 ReceiveModemCommand:
OK


This line here is from the .BAK file.

18:31:55:809 [230858752] m=101,0 ModemScanForModems: Detected modem tty.usbserial-10


Thank you.

Regards,
Pancho
Pancho
New member
Username: Pancho

Post Number: 22
Registered: 09-2005
Posted on Tuesday, November 17, 2020 - 10:06 am:   

Hi Bryce,

I was able to run both modems in the app now. I just restarted the computer and it now works perfectly.

Where do I inquire about the license fee?

Thank you.

Regards,
Pancho
Bryce Norwood - NowSMS Support
Board Administrator
Username: Bryce

Post Number: 8375
Registered: 10-2002
Posted on Tuesday, November 17, 2020 - 06:51 pm:   

Hi Pancho,


quote:

I got a new GSM modem (wavecom fastrack). Does the app support this modem because I cannot see it in the SMSC Connection whenever I am trying to add a new modem. I can see these lines in the log file. It looks okay.

18:31:55:671 [230858752] m=101,0 ModemScanForModems: Opened device tty.usbserial-10
18:31:55:794 [230858752] m=101,0 SendModemCommand: ATE0V1

18:31:55:809 [230858752] m=101,0 ReceiveModemCommand:
OK


This line here is from the .BAK file.

18:31:55:809 [230858752] m=101,0 ModemScanForModems: Detected modem tty.usbserial-10




I can confirm that there is a problem with the scan for new modems logic. As you have observed from the debug log, the modem is actually found, but there is inconsistency, and frequently the user interface will report "No USB modems have been detected on this server."

This was an error in how the user interface parses the results from the scan, and it has been fixed. To update, you can go to the Admin/System Configuration page, where an upgrade button should be displayed.

I should probably mention that there is a way to add modems that cannot be detected. The field that allows you to enter an IP address will accept a Unix device name, such as /dev/tty.usbserial-10 (of course, it is better if the scan works). Also worth mentioning is that if connecting to a modem by IP address, the expected format is ip.address:port ... if port is not specified, 23 (telnet port #) is assumed.


quote:

Where do I inquire about the license fee?




Telephone number listed here: https://www.nowsms.com/techsupport/contact

Or e-mail nowsms@nowsms.com

Regards,

Bryce
NowSMS Support
Pancho
New member
Username: Pancho

Post Number: 23
Registered: 09-2005
Posted on Wednesday, November 18, 2020 - 01:48 am:   

Hi Bryce,

I want to thank you and your team for the awesome support. My trial license will end soon, hopefully I can get the license and do further testing.

I honestly did not notice the update button, its just right in front of my nose. I will keep you posted if I see any irregularities.

Regards,
Pancho
Pancho
New member
Username: Pancho

Post Number: 24
Registered: 09-2005
Posted on Tuesday, November 24, 2020 - 10:59 am:   

Hi Bryce,

The crashing comes back again. This time I don't know why. When I go to System Configuration or any page it redirects me to the login page and the app crashes saying "Site cannot be reached". I think I need to mention to you that I have an Apache installed in the machine, I'm not sure if there is a conflict, but the port is different. Your app is using 8800 while my local is using 8080.

Regards,
Pancho
Bryce Norwood - NowSMS Support
Board Administrator
Username: Bryce

Post Number: 8379
Registered: 10-2002
Posted on Tuesday, November 24, 2020 - 05:07 pm:   

Hi Pancho,

I had a strange problem earlier today as well. I wanted to enable a database connection, and as soon as I did, it was like a crash, where the site couldn't be reached.

The secret was to run NowSMSInstall again (twice):

./NowSMSInstall and select option to remove. (This will not delete configuration data.)

./NowSMSInstall again and select the option to install.

Obviously, this is not an ideal solution, but it got everything working again. I suspect this will also work for you.

We are investigating the situation I experienced as it is 100% recreatable, and hopefully this will also give insight on the problem that you are seeing.

Regards,

Bryce
NowSMS. Support

P.S. - What version are you running?
Bryce Norwood - NowSMS Support
Board Administrator
Username: Bryce

Post Number: 8380
Registered: 10-2002
Posted on Tuesday, November 24, 2020 - 06:29 pm:   

Hi Pancho,

If you're running a version prior to 2020.11.18, download the latest version here (https://www.nowsms.com/download/macos/nowsms.tar.gz) or update in the web interface under Admin/System Configuration.

If the problem persists, I'd like you to look at the Mac "Activity Monitor" application.

Sort the list by process name and locate "NowSMS". It should appear in the list twice. (If you don't see it, from the top menu bar, select View and make sure "All Processes" is selected.) One NowSMS entry should have 1 thread and use almost no CPU time. A second NowSMS entry should have more than 1 thread and be using some CPU time. Each entry should have a PID number, where the PID number for the "1 thread" entry is less than the other PID number.

Do these PID numbers change when you are experiencing a problem?

Does either (or both) process disappear?

If you're still having a problem, I would be interested in seeing the SMSDEBUG.BAK file like before.

Regards,

Bryce
NowSMS Support
Pancho
New member
Username: Pancho

Post Number: 25
Registered: 09-2005
Posted on Wednesday, November 25, 2020 - 02:36 am:   

Hi Bryce,

Thank you for this information. I already updated the version and checked the Activity Monitor as you mentioned. I can confirm there are 2 instances running and so far, the crash does not happen anymore after the update. I will continue to monitor and message you again if I encountered a new problem.

Thank you.

Regards,
Pancho
Pancho
New member
Username: Pancho

Post Number: 26
Registered: 09-2005
Posted on Friday, December 11, 2020 - 06:05 am:   

Hi Bryce,

The crash is coming up again. I do not know what's causing it. After login, whenever I go to any other page within the app the browser will display "Site can't be reached". Then I will have to go back to the login page and the crashing cycle happens again. I am attaching the SMSDebug.bak file for your reference. Please let me know what's causing this crash.

Also, I am using the latest version.

Regards,
Pancho

application/octet-stream
SMSDEBUG.BAK (38.3 k)
Des - NowSMS Support
Board Administrator
Username: Desosms

Post Number: 6203
Registered: 08-2008
Posted on Friday, December 11, 2020 - 05:39 pm:   

Hi Pancho,

I want to confirm with you that this is version 2020.12.04, right?

The reason I ask is because we added a debug message to help troubleshoot the issue that you are experiencing. I don't see that debug message in your log, so I just want to make sure that we're looking at this correctly. I should see "ModemReceiveMessages: after ModemProcessReceivePDU".

Try editing SMSGW.INI, and under the [SMSGW] header, add StackSize=4096

In the original problem that you were experiencing, we determined that for some reason you were experiencing a stack buffer overflow that we could not recreate. But increasing the allocation did resolve the initial problem, and perhaps it needs to be larger. Note that this value is in KB, so 4096 = 4MB. If that also fails, try 16384 to see if that makes a difference.

Regards,

Des
NowSMS Support
Pancho
New member
Username: Pancho

Post Number: 27
Registered: 09-2005
Posted on Saturday, December 12, 2020 - 02:08 am:   

Hi Des,

Yes, this is to confirm that I am using the latest version (2020.12.04). I also added the line StackSize=16384 in SMSGW.ini I am still crashing. I am resending the SMSDEBUG.BAK file for your reference and I can confirm there's the "ModemReceiveMessages". I hope this helps.

Regards,
Pancho
application/octet-stream
SMSDEBUG.BAK (36.5 k)
Pancho
New member
Username: Pancho

Post Number: 28
Registered: 09-2005
Posted on Saturday, December 12, 2020 - 02:11 am:   

Hi Des,

I forgot to mention after editing the SMSGW.INI. I reloaded the sms.plist.

Regards,
Pancho
Bryce Norwood - NowSMS Support
Board Administrator
Username: Bryce

Post Number: 8384
Registered: 10-2002
Posted on Saturday, December 12, 2020 - 02:28 pm:   

Hi Pancho,

Thanks. We can clearly see and recreate the problem.

It appears that this has a actually been the same problem all along.

We are expediting a fix.

Regards,

Bryce
NowSMS Support
Des - NowSMS Support
Board Administrator
Username: Desosms

Post Number: 6204
Registered: 08-2008
Posted on Sunday, December 13, 2020 - 01:40 pm:   

Hi Pancho,

We’ve posted an update which will fix this.


Des
NowSMS Support
Pancho
New member
Username: Pancho

Post Number: 29
Registered: 09-2005
Posted on Monday, December 14, 2020 - 05:44 am:   

Hi Des,

Tried updating and reinstalling. I am stuck on the page "please wait This page will automatically refresh when the operation is complete". I have been waiting for more than 30 minutes. How long do I need to wait?

Thank you.

Regards,
Pancho
Pancho
New member
Username: Pancho

Post Number: 30
Registered: 09-2005
Posted on Monday, December 14, 2020 - 05:52 am:   

Hi Des,

I also checked the activity monitor and there no nowsms threads running. It seems version 2020.12.12 is crashing during installation?

Regards,
Pancho
Des - NowSMS Support
Board Administrator
Username: Desosms

Post Number: 6207
Registered: 08-2008
Posted on Monday, December 14, 2020 - 01:11 pm:   

Hi Pancho,

I have not seen any crashes during installation. But the fact that you don't see a nowsms process running suggests a fundamental problem.

Since you're on a Mac, I'd suggest going into System Preferences, Security & Privacy, and go to the "General" tab. Check to see if there is a warning about NowSMS being an unsigned app, where you need to click "Allow" for it to run.

I have seen some confusion if you run NowSMSInstall from a network share, where macOS code signing blocks the service from properly loading. So, if you are downloading the install on one computer, and then running the install from a different computer over a network share, this could be a problem. Copy NowSMSInstall to a local folder before running it.

It also might be a good idea to reboot...and see if the service gets loaded from the plist.

Regards,

Des
NowSMS Support
Pancho
New member
Username: Pancho

Post Number: 31
Registered: 09-2005
Posted on Monday, December 14, 2020 - 01:28 pm:   

Hi Des,

I waited the whole day and all it need was just a reboot. I am used to Mac machines that doesn't need to restart after installing an app. Anyway, the admin page is now working. Should I leave this line inside SMSGW.INI --> StackSize=16384 ?

Thank you.

Regards,
Pancho
Des - NowSMS Support
Board Administrator
Username: Desosms

Post Number: 6208
Registered: 08-2008
Posted on Monday, December 14, 2020 - 01:43 pm:   

Hi Pancho,

I've been noticing that these days, Mac machines need a reboot more often they used to.

For the past several days, I've been putting up with a weird issue where I was unable to click on links in e-mail messages. So I'd have to right-click, then copy and paste the link into Safari. I had quit both Mail and Safari several times, but the problem persisted.

Just after posting that reply to you, I thought to myself that rebooting was probably a good idea for this issue as well. Indeed, it fixed the problem.

We don't see any need for the StackSize setting, so I would suggest removing it. We believe that any adjustments to this setting were coincidental. There was a serious bug in our logging routines that was mishandling some patterns of message text.

Regards,

Des
NowSMS Support

Add Your Message Here, or click here to create a new discussion topic.
Post:
Bold text Italics Underline Create a hyperlink Insert a clipart image
Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Click here to create an account.
Username:
Password:
Options: Automatically activate URLs in message
Action:

Login Login / Register Logout Logout Search Last 30 Days Topics Topics