OMA email settings

OMA email settings SearchSearch

SMS & MMS Technical Forum » NowSMS Support - SMS Issues (Product Support Only) » Archive through February 02, 2006 » OMA email settings « Previous || Next »
Author Message
jihad khairallah
New member
Username: Jij

Post Number: 1
Registered: 01-2006
Posted on Wednesday, January 18, 2006 - 09:22 am:   

Hi
I want to address Mr Bryce Norwood from the support team.
Mr Bryce you mentioned on wednesday may 12 2004 that you sent Smtp/Imap settings to a Nokia 6600 without any problem.I checked also the xml file you sent and it seems that you used the FROM parameter which is not OMA defined yet.

I am trying to send email settings to a Nokia 6600 device without the FROM parameter because it is not OMA defined and i can't find its binary token,but no success.The device doesn't save the settings.I have found also that the FROM parameter is required for the SMTP settings.

Can you help me in finding the binary value of the FROM token or tell me how did you arrive to send settings successfully??

Thanks!
Bryce Norwood - NowSMS Support
Board Administrator
Username: Bryce

Post Number: 5463
Registered: 10-2002
Posted on Friday, January 27, 2006 - 07:14 pm:   

I'm at a bit of a disadvantage here, because you seem to be referring to another post out here somewhere, but I'm not sure what post you are referring to.

So I used the upcoming NowSMS 2006 release to generate OMA XML settings for e-mail. The resulting XML looks like this:

<wap-provisioningdoc>
<characteristic type="BOOTSTRAP">
<parm name="NAME" value="e-mail" />
</characteristic>
<characteristic type="APPLICATION">
<parm name="APPID" value="25" />
<parm name="PROVIDER-ID" value="user@domain.com" />
<parm name="TO-NAPID" value="INTERNET" />
<parm name="FROM" value="user@domain.com" />
<characteristic type="APPADDR">
<parm name="ADDR" value="smtpout.domain.com" />
<characteristic type="PORT">
<parm name="PORTNBR" value="25" />
</characteristic>
</characteristic>
</characteristic>
<characteristic type="APPLICATION">
<parm name="APPID" value="143" />
<parm name="PROVIDER-ID" value="user@domain.com" />
<parm name="TO-NAPID" value="INTERNET" />
<characteristic type="APPADDR">
<parm name="ADDR" value="imap.domain.com" />
<characteristic type="PORT">
<parm name="PORTNBR" value="143" />
</characteristic>
</characteristic>
<characteristic type="APPAUTH">
<parm name="AAUTHNAME" value="user" />
<parm name="AAUTHSECRET" value="pass" />
</characteristic>
</characteristic>
</wap-provisioningdoc>

You are correct that there is not a binary encoding defined for name="FROM" in the OMA Provisioning Content v1.1 specification.

But, there is not a requirement that a binary encoding exist for every "name=" setting. "type=", "name=" and "value=" all have WBXML encoding values defined for a blank attribute value prefix.

-bn

Login Login / Register Logout Logout Search Last 30 Days Topics Topics