Problems with NowSMS2008

Problems with NowSMS2008 SearchSearch

SMS & MMS Technical Forum » NowSMS Support - SMS Issues (Product Support Only) » Archive through January 22, 2009 » Problems with NowSMS2008 « Previous || Next »
Author Message
Brian Alu
New member
Username: Balunv

Post Number: 1
Registered: 11-2008
Posted on Monday, November 24, 2008 - 08:11 pm:   

Right now we are currently in the testing phase, utilizing this product on our Windows Server connected to 2 serial multi-modem's.

We are having an issue however with the application not running properly as a service. We have found that our ability to use the SMS features as well as connect to the web portion of the application ceases as soon as the application is closed. This basically means we have had to run the application and then disconnect an RDP session to keep everything running in the background.

We were under the impression this application ran as a service and that the front-end GUI would not need to be loaded 24/7 for all of the features to function. We are still utilizing the trial version, so we are hoping this is simple a "feature" of the trial version and not of the fully registered product.

I appreciate any insight that can be provided.
Des - NowSMS Support
Board Administrator
Username: Desosms

Post Number: 250
Registered: 08-2008
Posted on Monday, November 24, 2008 - 09:02 pm:   

Hi Brian,

NowSMS does run as a service.

It doesn't make any sense that the ability to connect to the web portion of the application would cease as soon as the application is closed.

I'd suggest enabling the SMSDEBUG.LOG (checkbox option on the "Serial #" page of the configuration dialog). And let's see if that provides any clues.

Is there anything unusual about your TCP/IP configuration, like on-demand routes being established to your server? I really can't imagine what this would be.

Enable the SMSDEBUG.LOG ... repeat your problem scenario, then post the SMSDEBUG.LOG as an attachment so that we can take a closer look.

--
Des
NowSMS Support
Brian Alu
New member
Username: Balunv

Post Number: 2
Registered: 11-2008
Posted on Wednesday, November 26, 2008 - 05:57 pm:   

Des,

I went ahead and enabled the logging, once I have some logs I will post them up. We are not doing anything unusual with our setup. We are running Windows 2008 Server, so I am curious if that may be the root cause of our problem or if you have noticed any issues running the services on a Windows 2008 system.
Des - NowSMS Support
Board Administrator
Username: Desosms

Post Number: 266
Registered: 08-2008
Posted on Wednesday, November 26, 2008 - 06:47 pm:   

Hi Brian,

We haven't noticed anything unusual with the services on Windows 2008 server. I do have that running on a test server in our office, and NowSMS is always running on it.

The service processes for NowSMS are SMSGWNT.EXE, SMSGWS.EXE, MMSCNT.EXE and MMSC.EXE.

You would need to check "Show processes from all users" to see these processes in Task Manager.

It may be curious to see when you do or do not see these tasks active.

I should also say, there is one problem that we have observed in some Windows Vista and 2008 environments. In some environments, the service thinks the trial has expried, while the configuration utility says that everything is ok.

In this case, the service basically does not run at all. (SMSGWNT.EXE and MMSCNT.EXE are active, but the other processes are not.) So, it is not selective, like you describe.

An updated version of NowSMS which addresses this issue is available for download at http://www.nowsms.com/download/nowsms200811.zip.

--
Des
NowSMS Support

Login Login / Register Logout Logout Search Last 30 Days Topics Topics