E-mail Client Provisioning on P900/P910 ?

E-mail Client Provisioning on P900/P910 ? SearchSearch

SMS & MMS Technical Forum » NowSMS Support - SMS Issues (Product Support Only) » Archive through July 14, 2005 » E-mail Client Provisioning on P900/P910 ? « Previous || Next »
Author Message
Andreas Froland
New member
Username: Afroland

Post Number: 5
Registered: 03-2005
Posted on Tuesday, April 19, 2005 - 11:48 am:   

Hi Bryce

Can you help me with e-mail Client Provisioning on P900/P910 ?

Sending E-mail CP using OTA or OMA seams to be a dead end for SEM devices in general, (- only OTA for GPRS/APN and SyncML works). Using Nokia Smart Messaging to T630 however works (see below). I can also see that my operator(s) can send e-mail provisioning to my P900/P910 using what indeed looks like Smart Messaging.

Trying to send a similar Smart Message using NowSMS to P900/P910 makes the P900/P910 request a password (PIN code) that I can’t guess. (it is not the PIN code of the SIM card)

I’m trying to send following: (Works on T630, except that it ignores IM for IMAP and set it to POP3 (default))

I have tested using you web interface for SMS text messages and using URL.

//SIAP11
Email configuration
Mname:Company_access
Muid:Username
Mpwd:secretpw
Madr:Username@serv.provid.net
Mrcv:imapserver.provid.net
Msnd:smtpserver.provid.net
Mpro:IM

Btw: I have been trying to locate a Ericsson or SonyEricsson document for Smart Messaging including provisioning for e-mail but without success, - any one with a working link ?

Cheers
Andreas
Bryce Norwood - NowSMS Support
Board Administrator
Username: Bryce

Post Number: 4381
Registered: 10-2002
Posted on Tuesday, April 26, 2005 - 02:53 pm:   

Hi Andreas,

I just tried sending the above to a K700i, and it worked properly.

On a T630, I had the same problem with the account being set for POP instead of IMAP.

I also noticed some stray characters in some of the parameters. Smart messaging expects a line feed character between lines (not the normal carriage return/line feed combination). So if you're submitting through the web interface, leave it all on one line, and put \n wherever you would normally put a line feed. NowSMS will replace \n with a line feed character when sending out the message.

That said, I tried moving the "Mpro:IM" line around to reorder the document, and I couldn't get the T630 to recognise it. So I've basically run out of ideas on that one.

By contrast, I didn't have any problem on the P900. (Although if I used carriage return/line feed line breaks instead of \n, the account was configured for POP3 instead of IMAP, and there was a garbage character at the end of various fields.)

So I'm not sure why you would be asked for a PIN. I can't imagine what PIN that would be, as I definitely don't see it sending to my P900.

I haven't seen any SonyEricsson documents on this type of configuration ... only the Nokia Smart Messaging spec.

-bn
hummer
Unregistered guest
Posted on Sunday, May 01, 2005 - 06:28 am:   

sdiofsdhf

Login Login / Register Logout Logout Search Last 30 Days Topics Topics