MMS - 23.140 Schema REL-5-MM7-1-2

MMS - 23.140 Schema REL-5-MM7-1-2 SearchSearch

SMS & MMS Technical Forum » NowSMS Support - MMS & Advanced Issues (Product Support Only) » Archive through July 14, 2004 » MMS - 23.140 Schema REL-5-MM7-1-2 « Previous || Next »
Author Message
Nisan Bloch
New member
Username: Nisof

Post Number: 1
Registered: 03-2004
Posted on Thursday, March 18, 2004 - 03:45 pm:   

Hi

I am using NowSMS ver 5 -

We are using a VASP provider who generates this error (statuscode: 4003) when we try use REL 5 1.2 of the schema. They say they only support 0.9.

<?xml version='1.0' ?><SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"><SOAP-ENV:Body><SOAP-ENV:Fault><faultcode>Client</faultcode><faultstring>upsupported operation</faultstring><details><statuscode>4003</statuscode><statustext>the operation(http://www.3gpp.org/ftp/Specs/archive/23_series/23.140/schema/REL-5-MM7-1-2#SubmitReq) is not supported</statustext></details></SOAP-ENV:Fault></SOAP-ENV:Body></SOAP-ENV:Envelope>

I have attached the debug log (with details *** out).

My question is; is their anyway to control the versions used in the SOAP packets?

thanks

Nisan

application/octet-streamDebug log
MMSCDEBUG.LOG (7.7 k)
Bryce Norwood - NowSMS Support
Board Administrator
Username: Bryce

Post Number: 2156
Registered: 10-2002
Posted on Thursday, March 18, 2004 - 06:54 pm:   

Hi Nisan,

I can't find any specifications that cover a REL 5 0.9 version of the schema.

I can find 1.0, 1.1, 1.2, 1.3 and 1.4, but no 0.9

Can you get a reference to at least the schema for this 0.9 version?

I'd have to check to see what fields we are using that might not have existed in some of these earlier versions.

We could probably adapt our requests to have configuration settings for different versions.

However, I'm wondering if 0.9 is even a real version ...
Nisan Bloch
New member
Username: Nisof

Post Number: 2
Registered: 03-2004
Posted on Friday, March 19, 2004 - 10:55 am:   

Hi Bryce

The operator is using Openwave products. I have the schema from them and it does refer to 0.09 (www.3gpp.org/MMS/Rel5/MM7/v0.09) - which is of course not on the 3gpp site.

I have pointed out that these sort of things are supposed to be backwardly compatable.

The schema is in the OpenWave API docs - should I email it to you.


thanks

nisan
Bryce Norwood - NowSMS Support
Board Administrator
Username: Bryce

Post Number: 2176
Registered: 10-2002
Posted on Friday, March 19, 2004 - 06:28 pm:   

Hi Nisan,

And Openwave has implemented v0.09??? Sigh.

I've downloaded a copy of the "Openwave MMS Library Developer's Guide". And I can see the schema URL that you reference ... which of course, is a non-existant URL. But I do see the schema is included in an appendix of the document, so that is good.

And I see one clear instance in their examples where they use an element that is not part of this 0.09 schema, but was actually introduced in the 1.1 schema. So they obviously do know about later schemas ...

Not to mention consistent XML name space errors in their examples (consistent with early versions of the MM7 specs). Sigh.

Looking over our MM7 implementation, I think we could add a configuration setting for specifying which schema to use.

And we can make the slight changes in the data to account for the slight differences between schema versions. My only concern is whether we might have to also purposefully include XML namespace errors to be consistent with the Openwave examples, or whether it will accept the correct encoding.

I'm going to go ahead and upload an implementation that allows the MM7 schema URL to be overriden. In an update that you can download from http://www.nowsms.com/download/nowsms550-patch.zip, it is possible to override the MM7 XML schema setting, but you will need to manually edit a configuration file.

For each outbound "MMSC Routing", there is a configuration file located in VASPOUT\AccountName\VASP.INI. In this configuration file, you can define the following settings under a [VASP] header:

MM7Version=
MM7Schema=
VASPID=
VASID=

The default value for MM7Version is 5.3.0

The default value for MM7Schema is http://www.3gpp.org/ftp/Specs/archive/23_series/23.140/schema/REL-5-MM7-1-2

There is no default value for VASPID and VASID, but I mention these settings as they don't seem to be documented anywhere else. If these settings are present, then the values specified will be included in the VASPID and VASID elements when submitting a message over MM7.

In the case of the Openwave interface, set the following in this file:

MM7Schema=http://www.3gpp.org/MMS/Rel5/MM7/v0.09

The default version number already matches the one in the Openwave examples.

Similarly, if you are receiving messages back from the MMSC (or accepting messages from a VASP that only supports an older schema), similar settings have been implemented for the "MMSC VASP" definitions.

For each inbound "MMSC VASP", there is a configuration file located in VASPIN\AccountName\VASP.INI. In this configuration file, you can define the following settings under a [VASP] header:

MM7Version=
MM7Schema=

The default values for these settings are the same as described above.

Let me know how this works for you with the Openwave MM7 connection.

-bn
Nisan Bloch
New member
Username: Nisof

Post Number: 3
Registered: 03-2004
Posted on Friday, March 19, 2004 - 07:13 pm:   

Hi Bryce

Great - thanks!! - this works perfectly. I will let you know as I exercise it a bit more.

I really get to dislike providers and upstream operators who claim to follow a certain spec or protocol and then have all sorts of things where they do it differently..

nisan

Login Login / Register Logout Logout Search Last 30 Days Topics Topics