SMS not send out when using accounting callback with SMSCRoute

SMS not send out when using accounting callback with SMSCRoute SearchSearch

SMS & MMS Technical Forum » NowSMS Support - SMS Issues (Product Support Only) » Archive through February 09, 2012 » SMS not send out when using accounting callback with SMSCRoute « Previous || Next »
Author Message
KKW
New member
Username: Kkw

Post Number: 37
Registered: 01-2009
Posted on Friday, August 05, 2011 - 01:37 am:   

HI Des,

we have a new test setup for using the accounting callback with SMSCRoute parameter but the sms failed to send out to the route that return by the callback url

i have to e-mail the debug log and config to nowsms@nowsms.com with Attention: Des in the subject line

pls help to take a look,

thx
kk
Des - NowSMS Support
Board Administrator
Username: Desosms

Post Number: 3390
Registered: 08-2008
Posted on Friday, August 05, 2011 - 01:19 pm:   

Hi kk,

I could not find any e-mail ... can you please resend?

If you are returning the SMSCRoute= value in response to a PreAuth callback, and the message is being submitted via HTTP, add SMSAccountingPreAuthPerRecip=Yes to the [SMSGW] section of SMSGW.INI.


--
Des
NowSMS Support
KKW
New member
Username: Kkw

Post Number: 38
Registered: 01-2009
Posted on Monday, August 08, 2011 - 04:36 am:   

Hi Des,

try SMSAccountingPreAuthPerRecip=Yes still same problem, i just resend the log again

thx
kk
Des - NowSMS Support
Board Administrator
Username: Desosms

Post Number: 3396
Registered: 08-2008
Posted on Monday, August 08, 2011 - 12:53 pm:   

Hi kk,

I'm still not seeing any log files. Can you try a test message with no attachments to see if that gets through?

--
Des
NowSMS Support
KKW
New member
Username: Kkw

Post Number: 39
Registered: 01-2009
Posted on Tuesday, August 09, 2011 - 02:29 am:   

hi des,

i just resend the email without attachments to both nowsmstech@nowsms.com and nowsms@nowsms.com, pls take a look
Des - NowSMS Support
Board Administrator
Username: Desosms

Post Number: 3408
Registered: 08-2008
Posted on Wednesday, August 10, 2011 - 05:29 pm:   

Hi kk,

Sorry for taking so long to get back to you. I did finally receive the log files yesterday.

This is a quirk of NowSMS deciding that the connection is a receive only connection, because of the way it is configured.

The quickest way to resolve this issue is to enable transceiver mode for the SMPP connection under "Advanced Settings", assuming that your provider supports transceiver connections.

If your provider does not support transceiver connections, add a dummy entry to the "Preferred SMSC Connection for" list in that connection. Any entry even an invalid one, such as the text invalid, will be enough to work-around this quirk.

I'm going to consult with engineering to change how receive only connections are configured in future releases. This configuration assumption might have made sense before accounting callbacks were allowed to control routing ... but it does confuse things when routing is controlled exclusively by accounting callbacks.

--
Des
NowSMS Support
KKW
New member
Username: Kkw

Post Number: 40
Registered: 01-2009
Posted on Thursday, August 11, 2011 - 01:57 am:   

Hi Des,

thx for yr advise and tested ok by setting in transceiver connection or adding dummy entry to the Preferred SMSC Connection for"

now one problem left is the Delivery Report received by nowsms didn't relay back to the sender

pls help to take a look

thx
kk
Des - NowSMS Support
Board Administrator
Username: Desosms

Post Number: 3413
Registered: 08-2008
Posted on Thursday, August 11, 2011 - 12:13 pm:   

Hi kk,

It is an unusually long message ID, but I can see from the logs that it is being successfully resolved and converted back into the NowSMS message ID.

Make sure that the SMPP account that is sending the message (testsms3 under "SMS Users") has the attribute enabled to receive messages ("Accept received messages for this user").

--
Des
NowSMS Support
KKW
New member
Username: Kkw

Post Number: 41
Registered: 01-2009
Posted on Friday, August 12, 2011 - 04:21 am:   

Dear Des,

you right, forgot to enabled to receive messages ("Accept received messages for this user").

thx for yr advise.
kk

Login Login / Register Logout Logout Search Last 30 Days Topics Topics