OMA OTA SETTINGS IN ITALY

OMA OTA SETTINGS IN ITALY SearchSearch

SMS & MMS Technical Forum » NowSMS Support - SMS Issues (Product Support Only) » Archive through April 16, 2015 » OMA OTA SETTINGS IN ITALY « Previous || Next »
Author Message
santino maio
New member
Username: Tynosan

Post Number: 1
Registered: 02-2015
Posted on Tuesday, February 17, 2015 - 12:01 pm:   

Dear Sirs,
my company needs to send to its customers some OMA OTA Settings, to let
remote mobile phones connect to internet through some specific servers
(proxy).
For this reason, we tried to use your software with a usb MODEM and some SIM from different mobile operators: TIM, Vodafone
and Wind.
Unfortunately, while we have no problem sending sms, we cannot send a
single OMA OTA Message.
The results with different operators were:
- TIM: Sending seems ok, but messages are not received by phones.
- Vodafone: Sending gives an error CMS 500.
- Wind: Sending seems ok, but messages are not received by phones.
May we try some different configurations to send these kind of message
in our country?
Thank you in advance for your kind support.
Des - NowSMS Support
Board Administrator
Username: Desosms

Post Number: 5207
Registered: 08-2008
Posted on Monday, February 23, 2015 - 02:04 pm:   

Hi,

Sorry for the delay in response, but there is no easy answer for this.

My first question would be ... are you sure the receiving phones in question actually support OMA OTA? This protocol was widely supported about 10 years ago in the pre-Android/pre-iPhone world, but relatively few Android phones support it today.

The next thing I would suggest is sending a message to the modem phone number. Obviously, the modem is not going to process it as an OTA...but you should see binary SMS messages being received. Does the data in the received message (SMSIN log) match the data in the sent message (SMSOUT log).

OMA OTA messages are encapsulated in a WAP Push message, so another thing to check is to see if simple WAP push SI messages can be sent. Again, the modem sending to itself is a good test.

If WAP Push messages cannot be sent/received, then it is possible that the operator is actively blocking mobile originated WAP Push messages. See this article for some settings to try: http://www.nowsms.com/wap-push-att-usa-gsm-modem

--
Des
NowSMS Support

Login Login / Register Logout Logout Search Last 30 Days Topics Topics